Google Earth Hacks blog

Everything you need to know about Google Earth
(return to Google Earth Hacks)

News round-up for Google Earth 4.3

Filed under: Site News — by at 2:37 pm on Wednesday, April 16, 2008

As you certainly know by now, Google Earth version 4.3 has been released.  It has a bunch of great new features and already has generated a lot of reviews, screenshots and videos.  Here are some of the best we’ve seen so far:

Download it! — First up, you need to download this latest version.  Get it straight from Google, or use our download page.

Google LatLong: Introducing Google Earth 4.3 — The official announcement from Google, with a list of new features.

Google Earth Blog: Video Demo of Google Earth 4.3 — A great tour of the new features, created by Frank Taylor.

Google Earth Tour — Another video tour, this time directly from Google.

Digital Earth Blog: Google Earth 4.3 thoughts, screenshots and a video — A brief review of the new features found in 4.3

Mashable: Google Earth 4.3 Released — An overview from Mashable.

Google Earth Blog: New Navigation Gadgets in Google Earth 4.3 — A video from Google about the new nav gadgets, along with a list of keyboard and mouse shortcuts.

Digital Earth Blog: Google Earth vs. Virtual Earth in Denver — A quick look at how the two products match up visually.

That should give you all the information you need for Google Earth 4.3.  If you know of any unique item that I’ve missed, feel free to tell us in the comments.  Have fun!

2 Comments »

Comment by Paul

July 9, 2008 @ 4:39 pm

This Google Earth has a problem as for some reason wont contact server under 1 users profiles. But if I log into another user it comes up fine.
I note on other forums. Plenty of other people are having logging in problems.
It was working fine then when tried again it came up with random yellow lines over countries.
So did a repair and reinstall to no avail.
Didnt realise at time other user on compuetr had no problems at all.
As far as I can tell settings are the same for both users.As disabled firewall etc and no difference at all
The working side under help it says server kh.google.com
The defective user side it doesnt show anything there at all. Just Server and nothing at all.
Tried uninstalling and reinstalling etc and no luck and checked registry for keys before installing.
Still problem exists.
Tried various help items and reached a blannk wall.

Comment by Paul

July 9, 2008 @ 4:42 pm

Forgot to mention if I create a new user profile on Computer it works fine. So some tech expert indicate what is wrong.?

RSS feed for comments on this post. TrackBack URI

Leave a comment

XHTML: You can use these tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>