PDA

View Full Version : Time Slider affects display of placemarks



terrypin
01-25-2011, 07:04 PM
This darned Time Slider! If I have placemarks checked, so that their icons and labels are visible, as soon as I checkmark a track (imported from a GPX file, created from a GPS record) the placemark's label disappears. It only reappears when I hover near the icon (or uncheck the track).

Anyone know what's going on here please?

I'd just like to be able to see all the tracks and placemarks that I've selected.

I suspect I'll have to edit each GPX to remove its timestamp data and re-open those in GE.

As raised in my other recent post about the timer slider, if only there was a simple toggle switch to turn the thing on or off. :(

--
Terry, East Grinstead, UK

Munden
01-26-2011, 12:02 AM
Firstly, I'm sorry if I missed a previous post about the time slider. I ran into an issue and found that they changed how it works with placemarks.

Edit a placemark or folder, etc. Go to the View tab. At the bottom you'll see the 'Date/Time' field. There is a "None" option that should mean your placemark will ignore the time slider.

However, that doesn't sound like an issue with the time slider. If I understand what you're saying, the label on a placemark disappears if there is a track from a different upload, yes? I'm not sure but there might be nothing you can do about that. It sounds like there are two objects near each other and GE is making a decision about what to show you when they overlap. It might have something to do with one being 'Clamped to the Ground' and one not being so in the Altitude tab (choice is by Altitude on the top row of that tab)

Wish I could offer more help, but the problem seems a little vague in my mind from the description. The most 'suspicious' thing to me is that the track would be imported and might have some odd setting on it like the Altitude thing I just mentioned. I'd focus on that.

terrypin
01-26-2011, 02:35 PM
Thanks Munden.

There are really several aspects of this Time Slider that puzzle me. But dealing with the subject issue (disappearing placemark names), your explanation makes sense. I see now that it's not a Time-Slider problem, but a consequence of elements 'competing' for display.

However, with apologies for swiching subjects, I'd like to pursue your comments about the track properties please. Properties > View > Date/Time for these tracks is set to 'None' (the default), but it appears to have no influence on the Time Slider behaviour or display of the track, as you see:

7265

The only way I've found so far to ensure that a track is displayed fully is to place the start and end markers at the extreme ends, as Appletom pointed out in my earlier thread:
http://www.gearthhacks.com/forums/showthread.php?14975-Time-Slider-puzzle

But if I have say a dozen tracks, representing files recorded with GPS during a walking holiday, I have to do that for every one, individually. Depending on how the markers are positioned (seems arbitrary, but I'm sure there's some logic!), that might need up to 3 careful clicks and drags. There appears no way to just switch OFF the Time Slider (TS), so that all timestamp data in any track is ignored.

There's other puzzling behaviour too. For example, sometimes (not always!), when 'playing' the TS, the start marker will suddenly take off and start following the end marker! It's probably the same thing that makes the start marker often 'shake' when you drag the end marker, who knows!

--
Terry, East Grinstead, UK

terrypin
01-26-2011, 05:01 PM
Hmm - I replied to this an hour or two ago, at some length, but it hasn't turned up. I didn't take a copy so looks like I'll have to redo it from scratch, darn it. No time now but will try later.

--
Terry, East Grinstead, UK

terrypin
01-26-2011, 08:10 PM
OK, second attempt to send my reply. Briefer this time!

On the subject issue, your explanation makes sense. Not a Time Slider (TS) issue, more a competition over display.

But I don't follow your other point about Date/Time. In fact tpstigers appears to be saying something similar (but not the same) in this post

http://www.gearthhacks.com/forums/showthread.php?15515-How-to-see-several-GPS-tracks-at-once&p=58764&viewfull=1#post58764

so here's an extract from my reply to him:

Here, that setting in Properties makes no difference.

http://dl.dropbox.com/u/4019461/GE-T...meSlider-1.jpg (http://dl.dropbox.com/u/4019461/GE-Tracks-TimeSlider-1.jpg)

The only way I've found of seeing the whole track is to place the start and end sliders of the Time Slider at the extreme ends. As advised by Appletom in an earlier thread. That can take up to 3 careful clicks/drags.

I'm even thinking of bringing in a KML file of the track, as well as the GPX, just to get simple displays. The animation (arrow moving along track) is fine, but the downsides are annoying.

--
Terry, East Grinstead, UK

terrypin
01-26-2011, 08:58 PM
What's going on here? I sent another reply, about half an hour ago. That too seems to have sunk without trace.

--
Terry, East Grinstead, UK

terrypin
01-27-2011, 08:31 AM
OK, thanks to Appletom for investigating and advising me "I'm guessing your posts got caught somehow in a changed security setting." I too can finally see my (duplicated) posts.

Edit: But only after a search. The actual thread still doesn't appear in the main list.

--
Terry, East Grinstead, UK