View Full Version : GE crashes

09-22-2005, 12:36 AM
This problem I'm sure has very little to do with any bug in GE war. Whenever I download the cotton, oil, or diamond kml, it downloads and begins to display, but if the entire field or a large portion of it is in the frame, I get a message that "GE has encountered an error and needs to close." and it tries to report a bug to google. I have no problems with other KMLs or with anything outside of GEwar; i assume that the problem is simply that my computer is struggling and failing to display the huge number of placemarks for each field.

< -- detailed description of my problem -->
When I zoom in far to the area, so that only a small part of it is visible, then enable the overlay, I see the placemarks which are within my frame, and I can see all of them in the left-hand Places list, but when I zoom out, it crashes. The results are the same when I start on another part of the map and slowly scroll over.

I have tried decreasing the pixels in the display area, and also changing the cache size (although i don't know which way would be to my benefeit) but to no avail.

I have a 2 gig amd processor, 512 megs of ram. I have shut down all other applications and tried to launch google earth then the kml from a file, no luck. I just upgraded to the latest version of google earth, but experienced the problem before and after the update. Oddly, I have succesfuly created cotton, oil, and diamond fields before and I have no idea what caused the change in performance.
< -- end extraneous info -->

If anyone has experienced this before, or has any suggestions to decrease memory usage, and allow myself to plant fields, please let me know.


09-22-2005, 12:40 AM
I used to have that more often but it is relatively better now...

09-22-2005, 12:45 AM
wow that is alot of typing lol :clap:

09-22-2005, 12:48 AM
xp sp2,
2 gig amd processor, 512 megs of ram
The only things running in the background are anti-virus, firewall, and spyware detector.

09-22-2005, 12:50 AM
ok first look if you're using directx or opengl for graphics.
If you're using directx, switch to opengl.
And visa versa.

Make sure you don't have any software exchange program online as Kazaa or Edonkey. Google Earth needs a lot of resources.

Third. Dont open too many KM* files at ones. Deactivate others.
And also, use the internal browser of Google Earth in Options.

*edit because other post came inbetween*
Try switching off Anti-Virus and spyware.
If you scan for spyware once every 2 days, and scan for virusses every week(scan every compressed file you download manually though), that should be enough.

09-22-2005, 01:48 AM
I've rebooted (more than a few times) and ended absolutely everything that is not a system process. My GE settings are such that that all layers, placemarks and overlays are turned off. No luck. I'm thinking switching GE to openGL mode might help, but I'm having a little trouble...

Thanks for the responses

also, I have no idea what you mean by the "internal browser"

09-22-2005, 02:44 AM
also, I have no idea what you mean by the "internal browser"
Google Earth has a browser built into it. I think its under view or options.

10-10-2005, 02:42 PM
Okay, I hate leaving something unfinished, but I have come up with no way to get around this problem. I guess its related to the amount of memory my computer is letting GE use, but I'm not sure how to fix it. I wanted to tie this up to give some input to anyone else who is having similar problems. I have come up with a technique to continue mining and planting:

Download the KML to your desktop
start GE. Make sure that the location of the field you are trying to use is not visible: if you are drilling for oil, go to north america, and for planting cotton, go to europe.
Open the KML file.
expand "drill for oil" / "plant cotton" in the Places box.
You can expand the list, and enable only "available area for..." sub-item. disable everything else.
zoom to that area, and zoom in very very far.
enable "active oil wells"
Zoom out so you can only see a dozen or so oil wells in the frame.
you can pan around and search for an empty spot, but DO NOT zoom out too far.
make sure the second item, which indicates whether or not you can build an oil well at the current location, is enabled.

btw, the internal browser is awesome and really helpful for use in GEwar. thanks. it can be enabled by disabling "show results in external browser" in the preferences tab of the options panel.