View Full Version : Opening KMZ file from a WebPage

09-30-2005, 04:17 PM
If I, for instance, create a KMZ file and mail it to myself; I just click on it [example myfile.kmz ]and GOOGLE EARTH opens right up and loads the KMZ file. But, if I put the KMZ in a WebPage [example: <a href="mycatalog/myfile.kmz"> ], it goes thru a WINZIP thing before I can open. It's not the KMZ file, because it is the same one in both examples. What do I have to do different in the HTML or what settings do I need to change. The HELP file was completely worthless: it told me to change a config file that I never heard of and can't find anyway. :crysmilie

10-02-2005, 04:13 AM
You need to change the way your browser handles the files, at the moment it thinks it has to open it in winzip, you want to set the program access defaults to Google Earth :) What browser do you use?

If that doesnt work, run the installer again, it will put the reg files back in the registry..


10-02-2005, 04:44 PM
Have Interrnet Explorer. Opens perfectly with Windows Explorer. Problem is if I put it in HTML on a WebPage. Is there an HTML command I need to put in???

10-02-2005, 07:28 PM
I've had a couple people report a problems with one of my KMZs that sounds similar to what you're seeing. We never could figure it out. There must be some obscure setting in IE or Windows or the web server that's causing this. Make sure you are using current version of GE and also you could try KML instead of KMZ.


10-06-2005, 09:45 AM
Kinlock, I was curious about your problem and had to give it a try myself. No problem when I put it on a webpage. The KMZ opened GE and loaded the file.

The only thing I can think of is that somehow in your file "associations" that KMZ got "associated" with the Zip program you use.

You could check it by opening any folder, going to "Extras > Folder Options > File Types" and check under the registered file types for KMZ and see if it is registered with any other program besides GE.

You can also check Winzip to see what files are associated with it as well.