View Full Version : Kmz files dont work????

08-02-2005, 04:37 PM
Well my problem started a few hours ago when i wanted to use a kmz file i downloaded. as always i dubble clicked on the file ... this time windows told me that it couldnt open the application. So I set the kmz file that i would be opened with GE . Now GE tell me: "fetch of [path to file] failed: Unsupported protocol" . When i open the filr with "File -> Open " ot works ....

Well anyone knows what i did wroong ????



08-02-2005, 06:19 PM
It could be that the kmz file was somehow corrupted. Try opening another kmz file, for example one from the download section. If this doesn't work try reinstalling GE.

08-02-2005, 06:36 PM
No these Files arent corrupted I have GE on another PC .. there it works just fine ...

Well I`ll try to reinstall GE.

08-09-2005, 08:53 PM
I've got the same problem. Did anyone already find a solution ?

08-09-2005, 09:34 PM
I don't know offhand, but my first advice would be to close Google Earth and upgrade to the latest version (http://www.googleearthhacks.com/forums/showthread.php?t=735). Beyond that, I'm not sure.

08-10-2005, 09:53 AM
Unfortunately this doesn't help. This problem even started just after I updated to the latest new version.
I also already tried to remove all settings in my home directory, but this doesn't help either.

08-10-2005, 10:02 AM
Ok, I have just resolved the problem. Just saved my settings, uninstalled google earth, installed it again, restored my settings, and ... it works ! :grin:

10-09-2005, 01:45 PM
I got this problem. As it didn't change after uninstall and reinstall, I went to the file explorer, tools/Options/Filetypes, selected kmz, clicked "restore" and it was ok.

02-08-2006, 01:52 PM
I can't open kml/kmz file with double click.
Every attempts discussed here are ko.
If I open kml/kmz file in Google Earth it works.
Could someone help me?

02-08-2006, 02:16 PM
Right click on the kml file. From the pop up window, left (normal) click "Open With". Then select "Choose Program".

Another window will pop up, use the browse button to navigate to C:\Program Files\Google\Google Earth\GoogleEarth.exe. Click OK, then tick the box that says "Always use the selected program to open this type of file."

Do the same with a kmz file.

If this doesn't work, in My Computer go to Tools-->Folder Options and click on the file types tab. Scroll down to kmz, highlight it, and press the delete button. Exit My Computer. Open My Computer again. Folder-->Folder Options-->File Types tab. Click "New" and type kmz into the box. Then click OK. From here, follow the instructions in the second paragraph above. Do the same with kml.

If none of this works, scream at the top of your lungs, pound your keyboard and punch your monitor. It still won't fix the problem but you will feel better (except for your knuckles, they will hurt from punching the monitor)

08-07-2007, 06:49 PM
How wonderfull, I have the same problem and I have tried everything. I have no clue wy it won't work.

Captain Hornblower
08-07-2007, 07:06 PM
But it has nothing to do with this problem, does it?


08-07-2007, 08:21 PM
It always says something about an unsupported protocol when I try to open a kmz file.

09-05-2007, 07:45 PM
I've had a similar problem for a while, where opening a KMZ or KML file would cause Windows to open Photoshop and dump the file into that program, leading to an obvious error message.
This would also happen to files downloaded through Firefox, IE or GetRight.

The solution was to go through the File Explorer Options menu, and using the Restore-button on the KMZ/KML suffixes in the File Type Association tab.