Results 1 to 3 of 3

Thread: Google Earth 5.0 traffic issue?

  1. #1
    Junior Member
    Join Date
    Feb 2009
    Posts
    2

    Default Google Earth 5.0 traffic issue?

    Hi,
    I recently downloaded Google earth 5.0 for another computer, when I went to enable the traffic layer I could not find it despite going through every option available. Does anyone know if this has been removed? Or am I just not looking in het right place!

    The version I run is 4.3.7284.3916 (beta) which has the traffic layer, if this is removed from version 5 and idea where I can a copy of 4.3? I have looked at a couple of websites listed in another post but they do not have the version of 4.3 that I am after.

    Thanks for any help.
    Rich

  2. #2
    Junior Member
    Join Date
    Aug 2006
    Posts
    15

    Default

    Take a look at MajorGeeks. They still have Downloads for the Version you're looking for. Don't delay. It won't be long before they Update to the New Versio.

    4.3.7284.3916

    http://www.majorgeeks.com/Google_Earth_d4659.html

    Ken:

  3. #3
    Junior Member
    Join Date
    Feb 2009
    Posts
    2

    Default Confused!

    Thanks Ken, I managed to download it just in time!

    I have removed Google Earth 5 and installed Google Earth 4.3.7284.3916 (beta) and the traffic layer is still missing, the only the thing that is different is one machine is running XP (can't see traffic) and one running Vista (can see traffic)

    Have I enabled/installed something without knowing that will have caused this or is XP not capable of showing traffic?

    Rich

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •