Results 1 to 7 of 7

Thread: Specific KMZ file crashes GE

  1. #1
    Junior Member
    Join Date
    Sep 2011
    Posts
    4

    Default Specific KMZ file crashes GE

    Hello,

    I have searched Google and these forums for a solution to my problem, but have found nothing specific to help me.

    I have GE 6.0.3.2197 Windows XP. I have had no previous problems with my KMZ files until this week. Just a few files will cause GE to crash/close with no messages - it just closes. I created these files some time ago and they have displayed 100% ok the last time I viewed them some months ago. Unfortunately my backed-up files also suffer the same crashing.

    I have cleared memory cache, deleted file cache, uninstalled GE, reloaded GE v5, uninstalled that, reloaded GE v6, deleted myplaces files, tried DirectX vs OpenGL, turned off atmosphere - and at each session the same KMZ files will crash, but the others are ok.

    Some of the problem KMZ files have photos "attached" to each placemark, some KMZ's don't, they are just placemarks. But good KMZ's have photos or not.

    I am at a loss and completely frustrated, as some of these files are of our overseas or local holidays with our kids, with comments and a photo at each place, and you just can replicate that again to the same "feel".

    I can't upload files within here as there are too large (28 mb).

    Any help would be appreciated.

    Gerard, Melbourne, Australia

  2. #2
    Super Moderator Munden's Avatar
    Join Date
    Aug 2006
    Location
    Maryland, USA
    Posts
    939

    Default

    Ouch, 28MB?

    Well, the first thing I would think is that something happened to your files and they were corrupted somehow. I know back a long time ago GE itself would sometimes corrupt a MyPlaces file and would just crash on trying to open it later. That hasn't happened to me in a long while though.

    I'd suggest going to Tools->Options and then the General tab. At the bottom, set KML Error Handling to either 'show prompts' or 'abort file' and try again.

    If it turns out to be the file, I can't imagine sifting through a 28MB file, but maybe the error prompt will help you find it. If not, some XML editors might be of help if you have something basic wrong like a missing tag of some sort.

    Wish I could offer more help.

  3. #3
    Junior Member
    Join Date
    Sep 2011
    Posts
    4

    Default

    Thanks. It's 28MB only because of the embedded photos (one at each placemark).

    I did as suggested and after it crashed I restarted GE and it came up with a diag box that said "Error while parsing file [path]myplaces.kml at line 80832, column 6: Unknown element <styleUrl>"

    The term 'gibberish' comes to mind.

    Now, the dumb thing is, I cleaned out GE files again, so Myplaces was essentially blank, then loaded the various XMLs with the Open command. When expanding the files (clicking on the + sign) all was ok. No crashes; I could view individual placemarks in the previously suspect XMLs and display properties. Hey fixed, I thought. So I moved the individual files up from the Temporary area into the top area, and saved Myplaces. Then closed and opened GE, clicked on known ok files, but as soon as I clicked on the previously problem file + sign (although as said above it was ok when first opened) it now crashed, and restarting GE showed the above msg. Bugger!

  4. #4
    Super Moderator Munden's Avatar
    Join Date
    Aug 2006
    Location
    Maryland, USA
    Posts
    939

    Default

    Well, that DOES point out the precise line in the file where it's freaking out. At some point there's a style tag that it doesn't think should be there. It could be the object it was for was terminated too early or some opening tag is missing.

    If you don't know much about XML or KML, there's not a lot of help I can offer other than maybe to paste some of the lines around that one for us to see. Other folks might have some ideas to help or XML programs to find problems.

  5. #5
    Junior Member
    Join Date
    Sep 2011
    Posts
    4

    Default

    Sorry if I take awhile to come back (work and family - wife does not see this problem as a priority - yeah, I know).

    The thing is working ok now! It still comes up with the debug error as above, I press Ignore, and GE continues, but I can now expand the placemarks on the ones that would previously crash it. Does not build confidence though.

    I know raw HTML code, but don't have a XML editor - any suggestions for a freebie one, and I can have a play with it?

  6. #6
    Super Moderator Munden's Avatar
    Join Date
    Aug 2006
    Location
    Maryland, USA
    Posts
    939

    Default

    I've only ever used XML Spy before. They still had a free version the last time I looked.

    There might be better ones out there, though. This does make me ponder finishing that KML editor I started. One of the reasons I'd made it was to use it to help people in cases like this so they could more easily fix a file.

    I tend to use plain text editors, though I tend to edit much smaller files and some editors can't deal with files of that size.

  7. #7
    Junior Member
    Join Date
    Sep 2011
    Posts
    4

    Default

    Thanks for your help. Very much appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •